1. IMPORTANT : Nouvelles mesures de sécurité - 2. Règles pour obtenir de l'aide dans les forums de support - 3. Restrictions des droits pour le groupe "Support suspendu"

Il est obligatoire de respecter les Règles de MyBB.fr : Version abrégée ou Version complète pour obtenir du support sur nos forums.

Les membres ayant un site/forum contrevenant aux règles de MyBB.support seront placés dans le groupe "Support suspendu" et ne bénéficieront plus du support du staff. Nous recommandons aux autres membres d'agir de même. Il ne s'agit pas d'un bannissement, le membre retrouvera son statut "normal" dès que sa situation sera conforme aux règles.

Nouveau : un Wiki en français : plus de détails.
Avant de soumettre votre problème, consultez-le, ainsi que la FAQ, sans oublier le moteur de recherche interne.


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Quelques soucis suite upgrade 1.6.16 vers 1.8.36
Tags » upgrade, migration, quelques, soucis, suite, 1616, 1836
02-11-2023, 13:52,
#1
Quelques soucis suite upgrade 1.6.16 vers 1.8.36

VERSION_MyBB : 1.8.36
Bonjour.

J'ai enfin pu faire la migration de la version 1.6.16 vers la version 1.8.36 en 2 étapes :
  1. upgrade 1.6.16 => la 1.8.4
  2. upgrade 1.8.4 => la 1.8.36
J'ai installé en local sur mon PC sous Wampserver une version MyBB 1.8.34 pour comparer un upgrade avec une version installée.

J'ai quelques soucis :
  1. je n'ai plus aucun plugin qui apparait dans "configuration => plugin" alors qu'ils y étaient avant l'upgrade (j'en ai installé un qui fonctionne en local sur mon PC et il apparaît).
  2. j'ai une page blanche quand je vais dans "configuration => plugin => mises à jour".
  3. le template utilisateur n'est pas le même que celui de la version installée sur mon PC, du moins je pense :
    1. pas de bouton mais un lien pour "nouveau sujet".
    2. dans l'encart de l'accueil "configuration, modération, administration, déconnexion" ne sont pas sur la même ligne.
    3. les sous-forums ne sont pas sur la même ligne.
Je n'ai pas fait totalement le tour du forum mais si je découvre d'autres erreurs je les mettrai à la suite.

Merci pour votre aide.
Reply
02-11-2023, 15:44,
#2
RE: Quelques soucis suite upgrade 1.6.16 vers 1.8.36
J'ai activé le "Type d'erreur" dans "Option serveur et optimisation" pour voir ce qu'il se passait et j'ai une multitudes de "warnings" qui sont apparût.
Je suis en PHP version 8.2.10 (cf. page d'accueil de l'administration du forum).

J'ai fait le test avec PHP en version 7.4 et je n'ai aucune erreur.

Pour l'instant j'ai masquer les warnings et erreurs.
Est-ce que c'est grave ou pas tous ces warnings ?

Merci pour votre aide.

PS : dans mon post précédent j'ai mis que j'avais installé en local la version 1.8.34 de MyBB mais j'ai installé la dernière, la 1.8.36.
Pouvez-vous corriger mon post ?
Merci.
Reply
03-11-2023, 21:49, (This post was last modified: 03-11-2023, 21:50 by spyto.)
#3
RE: Quelques soucis suite upgrade 1.6.16 vers 1.8.36
Bonsoir,

En ce qui concerne la page de configuration des plugins, il est possible qu'un plugin ne soit plus compatible avec 1.8.36 ou qu'un fichier "incongru" se soit glissé dans le dossier /inc/plugins :
https://community.mybb.com/thread-237395.html

1. Pouvez-vous indiquer la liste des plugins et leur n° de version ?

2. Je vois que l'admin est en fr. Avez-vous utilisé le dernier pack corrigé ou le dernier pack de langue que j'ai publié ?
Dans une version antérieure, j'avais commis une erreur en enregistrant certains fichiers en UTF-8 avec BOM au lieu de sans BOM !!! Il s'agissait notamment de :
  • inc/languages/french/admin/forum_management.lang.php
  • inc/languages/french/admin/tools_adminlog.lang.php
  • inc/languages/french/calendar.lang.php
  • inc/languages/french/global.lang.php
  • inc/languages/french/moderation.lang.php
  • inc/languages/french/search.lang.php
Voir ce post : http://mybb.support/thread-7959.html
Merci de le vérifier en téléchargeant les derniers packs mis à jour.

3. Pour tout ce qui concerne les défauts d'affichage, c'est sûrement dû à des templates non (ou mal) mis à jour au cours de l'upgrade.
Il faudrait comparer les différents templates du forum avec une version propre sur Wamp, avec une simple installation sans données.

Ou si vous vous en sentez le courage, allez voir dans l'archive 1.8.36 : install/resources/mybb_theme.xml  contient tous les templates corrects.

J'espère que exdiogene vous sera d'un plus grand secours. Wink

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply
03-11-2023, 22:04,
#4
RE: Quelques soucis suite upgrade 1.6.16 vers 1.8.36
Par exemple le template "header_welcome_block_member" chez vous contient ceci :

PHP Code:
<span style="float:right;">{$lang->welcome_current_time}</span>
        {
$lang->welcome_back} (<a href="{$mybb->settings['bburl']}/usercp.php"><strong>{$lang->welcome_usercp}</strong></a>{$modcplink}{$admincplink} &mdash; <a href="{$mybb->settings['bburl']}/member.php?action=logout&amp;logoutkey={$mybb->user['logoutkey']}">{$lang->welcome_logout}</a>)<br />
                <
span class="links">
                    <
a href="#" onclick="MyBB.popupWindow('{$mybb->settings['bburl']}/misc.php?action=buddypopup', 'buddyList', 350, 350);">{$lang->welcome_open_buddy_list}</a>
                </
span>
                <
a href="{$mybb->settings['bburl']}/search.php?action=getnew">{$lang->welcome_newposts}</a> | <a href="{$mybb->settings['bburl']}/search.php?action=getdaily">{$lang->welcome_todaysposts}</a> | <a href="{$mybb->settings['bburl']}/private.php">{$lang->welcome_pms}</a> {$lang->welcome_pms_usage

Alors que ce devrait être :

PHP Code:
<!-- Continuation of div(class="upper") as opened in the header template -->
    <
span class="welcome">{$lang->welcome_back} <a href="{$mybb->settings['bburl']}/member.php?action=logout&amp;logoutkey={$mybb->user['logoutkey']}class="logout">{$lang->welcome_logout}</a></span>
    </
div>
</
div>
<
div class="lower">
    <
div class="wrapper">
        <
ul class="menu panel_links">
            {
$usercplink}
            {
$modcplink}
            {
$admincplink}
        </
ul>
        <
ul class="menu user_links">
            {
$buddylink}
            {
$searchlink}
            {
$pmslink}
        </
ul>
    </
div>
    <
br class="clear" />
</
div
pour la v1.8.36

C'est dans Admin/Accueil/Templates/Default Templates/Entête templates.

Et il y en a surement beaucoup d'autres...
Je vous suggère de faire un clic droit sur la portion qui ne s’affiche pas comme il faudrait (sous Firefox) puis Inspecter.
Dans le code source vous pourrez alors "remonter" pour trouver sous forme de commentaire HTML : <!-- commentaire --> le nom du template incriminé. Cela vous facilitera le travail de comparaison avec les templates corrects sans avoir à tout comparer.

Dernier détail : je ne suis pas certain que le script mybb soit 10%% compatible avec les dernières version 8.x de PHP !

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply
04-11-2023, 19:31,
#5
RE: Quelques soucis suite upgrade 1.6.16 vers 1.8.36
Merci Spyto pour les infos.

J'ai déjà télécharger le correctif 1.8.36 et remplacer les fichiers incriminés, c'est fait Wink

J'ai récupéré la liste des plugins mais je ne peux plus voir leur version puisque rien ne s'affiche.
Ce que j'ai pu faire c'est d'éditer tous les fichiers présents dans le répertoire inc/plugins et de regarder dans l'entête si la version y était, donc...

Liste des fichiers et la version que j'ai pu glaner :
  1. akismet.php : version 1.2.2. Compatibility 1.6.x. By MyBB Group.
  2. board_messages.php : version 2.0.1. By Alan Crisp. Compatibility 1.4.x - 1.6.x.
  3. defaultprofile.php : version 2.0. Compatibility 1.6.x. By Dennis Tsang.
  4. forumcleaner.php : version 2.5.1. Compatibility 1.6.x. Forum Cleaner - A MyBB plugin to help Administrators keep things clean by Andriy Smilyanets.
  5. hello.php : version 1.0. MyBB 1.6 Copyright 2010.
  6. maj_afcavf.php : version 1.0 créé par l'ancien administrateur du forum. Compatibility 1.6.x.
  7. modchangeuser.php : version 1.0 by TimB. Compatibility 1.4.x - 1.6.x.
  8. pagemanager.php : version 1.5.2. Compatibility 1.6.x. Page Manager Plugin for MyBB. Copyright © 2010 Sebastian Wunderlich.
  9. phptpl.php : version 2.0 By ZiNgA BuRgA. Compatibility 1.x.x.
  10. rules_page.php : version 2.0 by Samuel. Compatibility 1.6.x.
  11. trivial.php : version 1.0 créé par l'ancien administrateur du forum. Compatibility 1.6.x.
Pour les templates je vais m'y pencher asap mais j'ai une question, peut-être surréaliste voir lunaire, mais je la pose quand même on ne sait jamais.

Est-ce qu'il est possible de récupérer tous les fichiers de ma version 1.8.36 sous Wamp (sans les fichiers de configurations qu'il faudra me dire de ne pas modifier) et de les copier sur le forum ?

En fait j'ai dans l'idée que tous les upgrade ont juste permis de passer à la dernière version de MyBB pour tous les fichiers y compris la base de données et sa structure.
Donc je pars du principe que, hormis les plugins que je peux ne pas remettre et en mettre d'autres à la place, ma version en place sur Internet étant en 1.8.36 peut être remplacée par ma version 1.8.36 sous Wamp Tongue
Je ne remplace que les fichiers pas la base de données puisque sa structure et ses données sont à jour...

Merci pour vos lumières les admins vous êtes au top.
Reply
05-11-2023, 18:10,
#6
RE: Quelques soucis suite upgrade 1.6.16 vers 1.8.36
Je constate qu'il y a beaucoup de plugins qui ne semblent pas compatibles avec 1.8.x !
Ça va être coton de corriger tout ça ! Blush


J’espère que vous avez désactivé tous les plugins avant de faire les différents upgrades...

Certes la structure de la BD est peut-être correcte, mais les plugins obsolètes sont inscrits dedans, ainsi que les templates (y compris les templates modifiés par les plugins).

Pour les templates, il est peut-être possible de "ruser".

Sur le forum "propre" 1.8.36 en local, sous phpMyAdmin, il est possible d'exporter la table "myb_templates" en prenant soin de valider l'option "DROP TABLE IF EXISTS".
Ensuite sur le forum en ligne, exporter d'abord cette même table par sécurité (on n'est jamais trop prudent - porte de secours), puis importer la table locale (si pas de modification du préfixe).

Garanti SGDG...

Une idée sans doute pas très catholique pour les plugins :
En FTP, pour tous les plugins qui sont dans le dossier /inc/plugins, rajouter une extension .bak par exemple à tous les fichiers .php et voir si la page Configuration/Plugins reste blanche. Si elle s'affiche, retirer une à une les extensions .bak jusqu'à trouver le/les coupables.
Cependant les tables et les modifs des plugins resteront dans la BD !

L'idée de remplacer les fichiers de la version en ligne par ceux de la version Wamp me semble utopique ! A moins que tout fonctionne sous Wamp y compris les plugins et les données, ce qui m’étonnerait.

De plus via l'upgrade les fichiers ont déjà été remplacés.
C'est la BD qui pose problème car elle contient tout, y compris ce qui ne fonctionne pas, hélas.

En tout cas, courage, car c'est un travail de longue haleine. Smile


Pour tout ce que je suggère, il va sans dire qu'il faut surtout faire un backup de la base et des fichier actuels !

PS : Si vous avez encore la version 1.8.4 sauvegardée et disponible, peut-être que ça vaudrait le coup de refaire en local les upgrades en prenant bien soin de désactiver le plugins d’abord si vous ne l'aviez pas fait, c'est le plus important ! Sinon ce post-scriptum est à oublier.

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply
05-11-2023, 19:27,
#7
RE: Quelques soucis suite upgrade 1.6.16 vers 1.8.36
(05-11-2023, 18:10)spyto Wrote:  J’espère que vous avez désactivé tous les plugins avant de faire les différents upgrades...

Oui je les ai tous désactivés comme préconisé avant de faire les upgrades.

(05-11-2023, 18:10)spyto Wrote:  Pour les templates, il est peut-être possible de "ruser".

Sur le forum "propre" 1.8.36 en local, sous phpMyAdmin, il est possible d'exporter la table "myb_templates" en prenant soin de valider l'option "DROP TABLE IF EXISTS".
Ensuite sur le forum en ligne, exporter d'abord cette même table par sécurité (on n'est jamais trop prudent - porte de secours), puis importer la table locale (si pas de modification du préfixe).

Je vais essayer pour voir ce que cela donne en respectant les sauvegardes.

(05-11-2023, 18:10)spyto Wrote:  Garanti SGDG...

Désolé mais qu'est ce que ça veut dire  Blush

(05-11-2023, 18:10)spyto Wrote:  Une idée sans doute pas très catholique pour les plugins :
En FTP, pour tous les plugins qui sont dans le dossier /inc/plugins, rajouter une extension .bak par exemple à tous les fichiers .php et voir si la page Configuration/Plugins reste blanche. Si elle s'affiche, retirer une à une les extensions .bak jusqu'à trouver le/les coupables.
Cependant les tables et les modifs des plugins resteront dans la BD !

J'ai déjà enlevé tous les fichiers du répertoire inc/plugins, il est vierge et ne contient que le fichier index.html.

(05-11-2023, 18:10)spyto Wrote:  L'idée de remplacer les fichiers de la version en ligne par ceux de la version Wamp me semble utopique ! A moins que tout fonctionne sous Wamp y compris les plugins et les données, ce qui m’étonnerait.

De plus via l'upgrade les fichiers ont déjà été remplacés.
C'est la BD qui pose problème car elle contient tout, y compris ce qui ne fonctionne pas, hélas.

Ok c'était une question utopique mais j'ai quand même demandé au cas où  Face-smile-4

(05-11-2023, 18:10)spyto Wrote:  En tout cas, courage, car c'est un travail de longue haleine. Smile

Je sais mais ce que je sais aussi c'est que je peux compter sur vos conseils avisés lorsque je me retrouve au pied du mur.

(05-11-2023, 18:10)spyto Wrote:  Pour tout ce que je suggère, il va sans dire qu'il faut surtout faire un backup de la base et des fichier actuels !

La sauvegarde actuelle n'est pas nécessaire puisque ça ne fonctionne pas top top  Dodgy
Par contre j'ai bien fait ma sauvegarde de la 1.6.16 (fichiers + BDD) donc je peux repartir de 0.

(05-11-2023, 18:10)spyto Wrote:  PS : Si vous avez encore la version 1.8.4 sauvegardée et disponible, peut-être que ça vaudrait le coup de refaire en local les upgrades en prenant bien soin de désactiver le plugins d’abord si vous ne l'aviez pas fait, c'est le plus important ! Sinon ce post-scriptum est à oublier.

Oups !!! Je n'ai pas fait de sauvegarde intermédiaire  Undecided



Pour finir je voulais savoir quelles sont les tables les plus importantes lors d'une migration car j'ai dans l'idée de ne garder que les tables nécessaires au bon fonctionnement du forum.
J'ai 79 tables et et je me disais qu'en récupérant les tables suffisantes à un forum de base pourrait être une bonne idée.
Par exemple je me fiche des anciens plugins je vais en installer d'autres et de pleins d'autres choses...

PS : existe-t-il un schéma de type Meurise par exemple qui montrerait toutes les tables et leurs champs avec les liaisons 1-1/1-n/etc... ?
J'espère m'être fait comprendre dans ma demande ci-dessus  Big Grin

Merci encore pour votre réponse.
Reply
05-11-2023, 19:45,
#8
RE: Quelques soucis suite upgrade 1.6.16 vers 1.8.36
Un truc du genre comme ça :

[Image: Tables-de-la-base-de-donnees-Schema-relationnel.png]
Reply
05-11-2023, 21:52,
#9
RE: Quelques soucis suite upgrade 1.6.16 vers 1.8.36
SGDG = « Breveté SGDG », abréviation de « sans garantie du gouvernement », est une mention légale relevant du droit des brevets.
« Breveté SGDG » était en France une mention légale dégageant l'État de toute responsabilité sur le bon fonctionnement effectif du dispositif breveté.


C'est-à-dire sans garantie car je ne l'ai jamais testé.

Je n'ai pas vraiment d'idée des tables importantes à privilégier, sûrement celles contenues dans une installation "neuve"...

Pas non plus connaissance d'un schéma Merise des tables de mybb. Posez la question chez les développeurs sur mybb.com. Ils devraient l'avoir, on ne sait jamais mais j’en doute ! Confused

Si j'ai d'autres idées, je reviendrai...

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply
16-11-2023, 22:13, (This post was last modified: 17-11-2023, 20:53 by r0o0minet.)
#10
RE: Quelques soucis suite upgrade 1.6.16 vers 1.8.36
Bonsoir à tous.

J'ai enfin réussi à migrer mon forum 1.6.16 en 1.8.36 mais non sans mal.
Si vous voulez aller vérifier vous pouvez Tongue et du coup me dire si vous voyez des coquilles  Dodgy
Le compte admin de connexion et le mot de passe sont les mêmes que décrit lors du post du sujet.

Voici les étapes que j'ai effectué pour repartir d'une base de données saine :
  1. installation en local d'une version complète 1.8.36 avec une configuration à l'identique de la version distante,
  2. connexion PhpMyAdmin en local pour exporter la base de données (1.8.36 vierge ou presque),
  3. connexion PhpMyAdmin en distant pour exporter la base de données qui avait été upgradée de la version 1.6.16 à la version 1.8.36 (Bdd bancale),
  4. comparaison de chaque table avec bien sûr des différences sur l'ordre des champs et les types des champs,
  5. requête SQL "maison", c'est à dire une requête qui sélectionne les champs dans l'ordre de la table destination puis export de celle-ci,
  6. import des fichiers mybb_xxx.sql un par un en n'oubliant surtout pas les "ALTER TABLE .... AUTO_INCREMENT=xx",
  7. une fois tous les imports dans les nouvelles tables effectués, connexion à la partie administration => Outils et Maintenance => Gestion du cache => Reconstruire et recharger tout,
  8. puis toujours partie administration => Outils et Maintenance => Recompter et Reconstruire,
  9. vérification de tous les paramètres dans la partie "Configuration" entre l'ancien et le nouveau forum,
  10. et pour finir installation du seul plugin dont j'avais besoin et modification des fichiers pour les nouveaux affichage des bandeaux et des couleurs d'en-têtes de forums.
Voilà j'ai, je pense, pu finir cette migration en y allant pas à pas (j'ai quand même recommencer depuis le début 4 fois Big Grin ) et je crois ne rien avoir oublié dans mes explications.
Si vous avez besoin d'un cador en requêtes SQL je suis votre homme Face-cool-2

Sinon j'ai 2 petits couacs qui ne sont sans doute rien mais que voilà.
  1. lorsque je suis connecté avec mon compte admin j'ai l'heure qui apparait en anglais en haut à gauche pour la dernière visite (1:30 pm, par exemple) alors que lorsque je me connecte avec un utilisateur enregistré j'ai bien l'heure qui apparaît à 13:30:45 (défini dans la configuration "Formats de date et heure" du forum).
  2. j'ai perdu le record d'utilisateurs en ligne qu'il y avait dans l'ancien forum  Undecided
PS : si vous avez besoin d'un compte utilisateur de test vous pouvez utiliser l'identifiant "testut". Vous pouvez changer son mot de passe pour vous connecter.

Merci pour votre aide.
Reply
01-12-2023, 23:21,
#11
RE: Quelques soucis suite upgrade 1.6.16 vers 1.8.36
Bonsoir à tous.

Premier couac résolu c'était la configuration de l'heure dans le profil et d'ailleurs j'en ai profité pour faire une requête SQL pour mettre tout le monde d'équerre.

Sinon pour mon 2ème couac est-ce que vous savez comment le résoudre svp ?

Merci pour vos réponses.
Reply
02-12-2023, 15:18,
#12
RE: Quelques soucis suite upgrade 1.6.16 vers 1.8.36
Ça semble se trouver dans la table mybb_datacache.

Après une recherche rapide, j'ai trouvé ce thread :
https://community.mybb.com/thread-16595-post-109682.html$

... et notamment ce message : https://community.mybb.com/thread-16595-post-109733.html#pid109733
qui dit : "Here's a simple script you can run to set the number and time to whatever you want. Just change the two values, as the comment says. [Image: tongue.gif]'

Je joins ce script (updatemostonline.php) à tout hasard...

A utiliser avec précaution (garder une copie de la table d'origine en cas...)


Attached Files
.php   updatemostonline.php (Size: 373 bytes / Downloads: 0)

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply




Users browsing this thread: 1 Guest(s)

Contact Us | MyBB.support | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication
 Translation utility provided by Regentronique